ProFTPD IAC Remote Root Exploit – CVE-2010-3867 (Remoto)

Descripción:
Esta vulnerabilidad permite a atacantes remotos ejecutar código arbitrario en instalaciones vulnerables de ProFTPD. La autenticación no se requiere para aprovechar esta vulnerabilidad por lo tanto es ALTAMENTE CRÍTICO.

Bug:
El problema es causado por un desbordamiento de búfer en el pr_netio_telnet_gets () para evaluar secuencias TELNET IAC. El informe oficial está presentado en el siguiente link.

Demostración:

Plataformas afectadas:
Todas

Versiones afectadas:
FreeBSD 8.1 i386, ProFTPD 1.3.3a Server
FreeBSD 8.0/7.3/7.2 i386, ProFTPD 1.3.2a/e/c Server
Debian GNU/Linux 5.0, ProFTPD 1.3.2e Server
Debian GNU/Linux 5.0, ProFTPD 1.3.3 Server
Debian GNU/Linux 4.0, ProFTPD 1.3.2e Server
Debian Linux Squeeze/sid, ProFTPD 1.3.3a Server
SUSE Linux 9.3, ProFTPD 1.3.2e Server
SUSE Linux 10.0/10.3, ProFTPD 1.3.2e Server
SUSE Linux 10.2, ProFTPD 1.3.2e Server
SUSE Linux 11.0, ProFTPD 1.3.2e Server
SUSE Linux 11.1, ProFTPD 1.3.2e Server
SUSE Linux SLES 10, ProFTPD 1.3.2e Server
CentOS 5, ProFTPD 1.3.2e Server
ProFTPD 1.3.2b Debian 4
ProFTPD 1.3.2b Debian 5
ProFTPD 1.3.2e Fedora 11
ProFTPD 1.3.2e Fedora 7
ProFTPD 1.3.2e Fedora 8
ProFTPD 1.3.3 Debian 4
ProFTPD 1.3.3 Centos 4
ProFTPD 1.3.3 Centos 5

Solución:
Instalar una versión de Proftpd >= 1.3.3c

Share

This entry was posted in bugs, updates. Bookmark the permalink.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

For security, use of Google's reCAPTCHA service is required which is subject to the Google Privacy Policy and Terms of Use.

If you agree to these terms, please click here.

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.