Publican código de ataque a nuevo ‘0-day’ de Internet Explorer

Microsoft está investigando las nuevas vulnerabilidades de día cero que dejan expuestos a los usuarios del navegador Internet Explorer a ataques de ejecución remota de código.

El código de explotación ha sido agregado a la herramienta Metasploit y se publicó un video para demostrar la gravedad.

Aquí está una breve descripción del problema publicado por VUPEN:

Se ha identificado una vulnerabilidad en Microsoft Internet Explorer, que podría ser explotada por atacantes remotos para tomar control completo de un sistema vulnerable. Este problema es causado por un error de usar-después-de-liberar dentro de la biblioteca “mshtml.dll” cuando procesa una página web que hace referencia a un archivo CSS (Cascading Style Sheets) que incluye varias reglas “@import”, que podrían permitir a atacantes remotos la ejecución de código arbitrario mediante una página web preparada especialmente.

VUPEN ha confirmado esta vulnerabilidad en Microsoft Internet Explorer 8 en Windows 7, Windows Vista SP2 y Windows XP SP3, y con Internet Explorer 7 y 6 en Windows XP SP3.

El código de explotación en Metasploit’s provee alguna información adicional:

Este módulo explota una vulnerabilidad de corrupción de memoria dentro del motor HTML de Microsoft (mshtml). Cuando analiza una página HTML que contiene una importación CSS recursiva, un objeto C++ se borra para y luego es reutilizado. Esto lleva a la ejecución de código arbitrario.

Según el video publicado por Abysssec Security Research, la explotación elude dos mitigaciones clave anti-exploit de Windows (DEP y ASLR) sin utilizar ninguna extensión de terceros.

Estos son los informes sobre que la vulnerabilidad primero fue publicada en un blog Chino de seguridad.

Nota de Segu-Info: Por otra parte Microsoft detalla en su Boletín (2488013) sobre factores atenuantes a esta vulnerabilidad:

* Uso de IE en Modo Protegido
* Modo restringido por defecto en Windows server 2003 y 2008
* Usuario con permisos restringidos, es recomendado pues la vulnerabilidad consigue solo los privilegios del usuario que ejecuta IE
* El atacante debe engañar al usuario para que visite un sitio con páginas preparadas para explotar la vulnerabilidad.

Traducción y notas: Raúl BatistaSegu.Info
Autor: Ryan Naraine
Fuente: Blogs ZDNet

Share

This entry was posted in bugs. Bookmark the permalink.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

For security, use of Google's reCAPTCHA service is required which is subject to the Google Privacy Policy and Terms of Use.

I agree to these terms.

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.